Theme
Daq3簡易操作手順書
ELMEC 2015/10/10
はじめに
本書は、Daq3(ダックスリー)ソフトウェアについて記載した取扱説明書です。
この度はELMEC製ADC用のデータ収録・表示ソフトウェアDaq3を導入いただきましてありがとうございます。
Daq3はELMECの長年に渡る計測の経験を生かし、ユーザーにとって使いやすく、理解しやすいソフトウェアを目指して作り上げました。PCと言う今やいずれの計測の現場にも欠かせないツールをプラットフォームにして、ADCと組み合わせる事で無限に広がるPC計測システムが実現できます。
ELMECのADCにより取り込まれディジタルデータに変換されたアナログ量は、指定されたサンプリング周波数と分解能によってデジタル化されます。この時サンプリング周波数が50kHzとするとこのようなデータが20μsec毎に1個作られています。このデータをDaq3はオシロスコープに似た画面で表示をします。表示の種類・方法はこの取説で述べられております。
これらのデータはELMEC標準の保存用データフォーマット.IMD(アイエムディー)ファイルと言う形式で保存されます。このファイルは他のELMECの解析ソフト群と互換性が有ります。
ELMECの解析ソフトには、DAOS2010、リアルタイムFFTのDAQ-WIN、生体データ解析に適したBIOMAS、ウエーブレット解析ソフトなどがあります。
生産ラインでの良否判定にこれらを応用する事で、広範囲なアプリケーションに対応ができます。自動車エンジンの官能検査にとって変わった「音振判定システム」はヒット商品の一つですが、ELMECでは創業以来約2000ものPC計測システムを構築広く産業に提供してまいりました。

用語
本書で使用する用語を以下のとおり定義する
| Term | Comment |
|---|---|
| Daq3 | ソフトウェアの名前、ダックスリーと呼ばれます。Daqとは、Data acquisitionの略称、データ収集のこと。 電圧や電流、温度、圧力、音などの電気の・物理の現象のデータを収集・計測する装置・システムのことを指す場合もある。 |
| Ch、channel | サンプリング時のチャンネル |
| ELMEC | (株)エルメック会社の英語名 |
| ADC | Analog-to-Digital Converterの略称。ADCコンバータ(アナログ-デジタル変換器) |
| DLL | Dynamic Link Libraryの略称、windowsソフトウェアの一種 |
| CSV | Comma-Separated Valuesの略称。ファイルの拡張名です。Microsoft Excelでは「CSV (カンマ区切り)」としている |
| IMD | ELMEC専用の生データファイルフォーマートです |
| PC | Personal Computer(パーソナルコンピュータ)の略称。大組織しか所有できないようなものではなく、個人用コンピュータ全般を指す呼称 |
特徴
Daq3は様々な機能を備えており、主な機能は以下の通りです:
- 最大16チャンネルまでの表示を256チャンネルから選択することができます。
- 各信号の表示レンジを0.001倍から1000倍まで15段階から選択できます。
- 時間軸は0.0001~10秒まで任意に設定できます。
- モニタ表示は、ノーマル表示(ストリップ、スコープ、スイープ)、FFT表示、デジタル表示が選択できます。
- 長時間の収録が可能で、大きなファイルを開くこともできます。
- カーソル機能により、自由な演算や検索ができます。
- さまざまなトリガに対応しています。
- 自由な生データ保存が可能です。
- リアルタイムで音声再生が可能です(PCにサウンドカードが必要です)。
- 64ビット対応。
- リアルタイムFFT表示
- 新規入力デバイスへの対応が容易で、二次開発も可能です。
ソフトウェアの構成
Daq3基本フレーム
基本フレーム
Daq3実行ファイル場所
32bit:Daq3\Bin\Daq3.exe
64bit:Daq3\Bin64\Daq3.exe
デバイス管理
入力デバイスDLLの管理。例えば、EC-2310 ADCに対応するため、Ec2310.dllファイルが必要です。
DLLファイル場所
32bit:Daq3\Bin\Plug-ins\Devices
64bit:Daq3\Bin64\Plug-ins\Devices
ファイル管理
各形式の生データファイル対応DLLの管理。例えば、CSV形式ファイルに対応するため、Csv.dllファイルが必要です。
DLLファイル場所
32bit:Daq3\Bin\Plug-ins\File Formats
64bit:Daq3\Bin64\Plug-ins\File Formats
関数管理
演算関数DLLの管理。例えば、生データを移動平均するため、Ave.dllファイルが必要です。
DLLファイル場所
32bit:Daq3\Bin\Plug-ins\Functions
64bit:Daq3\Bin64\Plug-ins\Functions
ファイルの構成
python
Daq3/ # Root フォルダー
├─ Bin/ # 32bit の Daq3 実行フォルダー
│ ├─ Daq3.exe # Daq3 実行ファイル
│ ├─ Log.txt # 実行ログ
│ └─ Plug-ins/ #
│ ├─ Devices/ # 入力デバイス関連の DLL(拡張可)
│ │ ├─ EC2310.dll # EC2310 Device
│ │ ├─ EcCan.dll # CAN Device
│ │ ├─ Mic.dll # Mic Device
│ │ ├─ EcMcc.dll # Mcc Device
│ │ └─ Ec2330N.dll # EC2320/EC2330 Device
│ ├─ File Formats/ # ファイル存取関連の DLL(拡張可)
│ │ ├─ Imd.dll # .Imd file
│ │ ├─ Imdz.dll # .Imdz file
│ │ ├─ Mic.dll # .Wav file
│ │ └─ Csv.dll # .Csv and .Txt File
│ └─ Functions/ # データ処理関数関連の DLL(拡張可)
│ ├─ Ave.dll # 移動平均処理
│ ├─ FFT.dll # FFT 演算
│ ├─ Freq.dll # F/V 処理
│ └─ PosM.dll # POS 歯無欠歯処理(例:3 歯から 1 歯を取る)
├─ Bin64/ # 64bit の Daq3 実行フォルダー(Bin フォルダーを参照)
├─ Language/ # 多言語パック保存フォルダー
├─ Manuals/ # Daq3 取扱説明書
├─ Para/ # Daq3 関連パラメータ保存場所
└─ Raw/ # 生波形記録時の保存場所操作画面紹介
Daq3画面は下記4つのエリアがあります
メインメニュー
メインメニューはファイル、設定、オシロとヘルプメニュー欄があります。
ファイルメニュー
各サブメニューを説明
| Item | Comment |
|---|---|
| 開く | Daq3保存された生データファイルを開く |
| ページ設定 | 印刷ページ内容を設定、詳しく[《印刷とページ設定》](#5.5 印刷とページ設定)にご覧ください |
| 印刷 | ページ設定より印刷する、詳しく[《印刷とページ設定》](#5.5 印刷とページ設定)にご覧ください |
| 最近使ったファイル | 最近使った生データファイル名はここに表示する |
| 終了 | Daq3ソフトウェアを閉じる |
設定メニュー
各サブメニューを説明
| Item | Comment |
|---|---|
| 環境設定 | Daq3環境関連のパラメータはここに設定する、詳しく[《環境設定》](#5.6 環境設定)にご覧ください |
| 言語を変更 | Daq3言語を切り替え、日本語、英語、中国語(簡体)、中国語(繁体)を対応済 |
オシロメニュー
各サブメニューを説明
| Item | Comment |
|---|---|
| 入力デバイス設定 | 各入力デバイスのサンプリングパラメータはここに設定する。例えば:チャンネル数、サンプリング周波数、タイマー種類、各チャンネルの変換値、トリガ機能など 。詳し[《入力デバイス設定》](#5.7 入力デバイス設定)にご覧ください |
| 関数処理設定 | 生データ表示前のデータ変換処理パラメータはここに設定する、詳しく[《関数処理設定》](#5.8 関数処理設定)にご覧ください |
| チャート表示設定 | 波形表示パラメータはここに設定する、詳しく[《チャート表示設定》](#5.9 チャート表示設定)にご覧ください |
ヘルプメニュー
Daq3と各DLLのバージョン情報はここに表示する
クイック操作ツールバー
クイック操作ツールバーはメインメニューの下に表示されます
各アイコン設定説明
Homeアイコン:チャート表示画面を切り替え
生データ収集していない場合、操作可
チャート表示画面は基本画面、FFT画面、デジタル画面の3つの表示画面があります。
マウスでHomeアイコンをクリックして切り替え可能、またはHomeアイコン右側の↓矢印をクリックして選択可能です。Openアイコン:生データファイルを開く
生データ収集していない場合、操作可
マウスでOpenアイコンをクリックして、ファイル選択ダイアログから生データファイルを選択します。
またはマウスでOpenアイコン右側の↓矢印をクリックして、最近使用した生データファイル履歴から選択します。Playアイコン:生データ収集スタート
生データ収集していない場合、操作可
生データ収集開始前、マウスでPlayアイコン右側の↓矢印をクリックしてチャート更新モードを選択可能です。
チャート更新モードについては、詳しくは[《チャート更新モード》](#5.10 チャート更新モード)をご参照ください。Stopアイコン:生データ収集停止
生データ収集中の場合、操作可Recordアイコン:生データ保存有効/無効を切り替え
RecordアイコンON時、生データを保存します。
RecordアイコンOFF時、生データを保存しません。Timerアイコン:指定時間保存有効/無効を切り替え
TimerアイコンON時、指定時間保存機能が有効になります。
TimerアイコンOFF時、指定時間保存機能が無効になります。
TimerアイコンOFF時、マウスでTimerアイコンをクリックすると、「保存時間設定」画面が表示されます。詳しい設定内容は[《保存時間設定》](#5.11 保存時間設定)をご参照ください。Soundアイコン:音声再生と停止を切り替え
同時に1つのチャンネルのみ音声再生可能です。
音声再生前、マウスでSoundアイコン右側の↓矢印をクリックして、音声再生チャンネルを選択します。Aboutアイコン
Daq3と各DLLのバージョン情報を表示します。
入力デバイスのクイック選択
入力デバイス選択とパラメータ設定は、メニューバーの[《入力デバイス設定》](#5.7 入力デバイス設定)と一致します。
データ収集前に、デバイスリストから必要なデバイス名を選択し、右側の「設定」ボタンを押すと、現在選択している入力デバイスのパラメータ設定ダイアログが表示されます。
チャート表示エリア
チャート表示エリアには基本画面、FFT画面、デジタル画面があります。同時に1つの画面のみ表示され、マウスでクイック操作ツールバーのHomeアイコンをクリックして切り替えます。
基本画面
デフォルトの波形表示画面で、データ収集と一般的な分析はすべてこの画面で行います。
詳しくは[《基本画面》](#5.12 基本画面)をご参照ください。
FFT画面
この画面はFFT分析専用です。
詳しい設定は[《FFT画面》](#5.13 FFT画面)をご参照ください。
デジタル画面
この画面は収集データのモニタリング専用です。
詳しい設定は[《デジタル画面》](#5.14 デジタル画面)をご参照ください。
状態表示エリア
状態表示エリアはメイン画面の一番下にあります。下図参照:
各表示内容の説明
- Daq3ソフトウェアの動作状態表示(計測中、保存中、保存完了、アイドルなど)
- 入力デバイス名の表示。波形ファイル読込み時は、ファイルの拡張子がここに表示されます。
- 入力デバイス(または波形ファイル)のチャンネル数。
- 入力デバイス(または波形ファイル)のチャンネル毎のサンプリング周波数。
- 経過計測時間を表示。波形ファイルの場合は、波形のファイル内での位置を表示します。
- リアルタイム収集時のデータバッファ表示
- システム時刻の表示
印刷とページ設定
印刷設定画面
印刷時、タイトル、作業者、会社名をここで編集できます。選択されていない項目は印刷されません。
印刷例
環境設定
Daq3操作用の環境設定画面です
各パラメータ説明
- ソフトウェア起動後自動計測スタートを設定する
- 最近使用したファイルリストの最大個数
- ログ出力の有無、およびログファイルサイズの設定。
- 自動保存時のフォルダー
定時保存とトリガ保存時に使用。 - 大ファイルモードファイルサイズ設定
ファイルモードは2種類:通常モードと大ファイルモード。ファイルサイズによって決まります。ファイルサイズはここで設定します。例:設定値500MBの場合、IMDファイルのサイズが500MB以上の場合は大ファイルモード、逆に500MB以下の場合は通常モードです。- 通常モード:一括読込みしてチャートに表示します。
- 大ファイルモード:表示部分のみ読込みます。
- リアルタイム生データ収集時、チャートに最大値/最小値を表示するかどうかをここで設定します。
- 選択しない:表示しない
- 選択する:生データ収集時、リアルタイムで最大値と最小値を演算し、チャートに表示します。
入力デバイス設定
ここにEC-2310の設定画面より、説明します
各パラメータ説明
サンプリング周波数関連設定
Item Comment カードID デバイスカードのID。1台のPCで複数の同一デバイスを計測する際に使用します。IDによってどのデバイスかを選択します。ID値は0~15から選択可能です。 チャンネル数 生データ収集時のチャンネル数(必ずハードウェア仕様内のCH数を設定してください) サンプリング周波数 1チャンネルあたりのサンプリング周波数です。単位:Hz - サンプリングタイマー設定
サンプリングタイマーには内部タイマーと外部タイマーがあります。外部タイマーを設定した場合、サンプリング周波数の設定は無効になります。
- サンプリングタイマー設定
トリガ設定
Item Comment トリガ種類 3種類から選択可:無/ソフトウェア/ハードウェア ソフト種類 トリガ種類で「ソフトウェア」を選択時、ソフトウェアトリガモードが有効になります ハード種類 トリガ種類で「ハードウェア」を選択時、ハードウェアトリガモードが有効になります トリガ回数 単位:回。設定値が0の場合、無制限 その他のパラメータ 詳しくは[《トリガ機能》](#6 トリガ機能)をご参照ください。ここでは省略します。 チャンネル変換仕様
Item Comment CH チャンネル番号 チャンネル名 指定チャンネルの名前、編集可 単位 指定チャンネルの物理値単位、編集可 電圧範囲 指定チャンネルの入力電圧範囲、編集可(一部のADC型番では入力電圧範囲がハードウェアで固定されているため、一致させてください) 物理値最小最大 指定チャンネルの物理値範囲、編集可
関数処理設定
収集した各チャンネルデータに対して処理を行い、処理後の波形を画面に表示します。
平滑処理
現在の波形データを指定した点数で平均化し、平滑化する処理です。移動平均とも呼ばれます。
下図は平滑処理前後の比較図です
F/V変換
波形の周波数(Frequency)を電圧(Volt)信号に変換します。波形データの周波数変化を確認できます。
F/V変換設定画面
各パラメータ説明
| Item | Comment |
|---|---|
| ロースライス値 | 歯識別用のロースライス設定値、単位:V |
| ハイスライス値 | 歯識別用のハイスライス設定値、単位:V |
| 1V表示の周波数値 | 変換後波形表示のため、1Vあたりの周波数を指定します。単位:Hz |
F/V変換表示例(上図設定による)
チャート表示設定
基本画面での波形表示の背景色、グリッド線の色などをここで設定します。
設定IDと設定名
Item Comment 設定ID 設定スタイル番号。ユーザーはここで設定スタイルを選択できます。 設定名 設定スタイル名。識別用です。 色設定
色設定は下図の説明をご参照ください
表示間隔設定
1フレーム内の表示データ量が多い場合、表示更新が遅くなることがあります(コンピューターの性能に依存します)。表示速度を向上させるため、指定間隔表示が可能です。デフォルト値は0(間隔なし表示)です。
チャート更新モード
生データをリアル収集時、データをスクロールするために、ストリップチャート、スコープチャート、およびスイープチャートという3つの更新モードがあります。
ストリップチャート(default)
このモードは、表示がスクロールしてロール紙に記録するチャートレコーダに似ています。このモードの最初のプロットは左から右にスクロールします。一番右側にある新しいポイントは、古い値として左側にずれてプロットされ続けます。スコープチャート
このモードは、表示を再描画するオシロスコープに似ています。新しいデータを受け取ると、最後の値を右側にプロットします。プロットがプロット領域の右枠に到達すると、プロットを消去して左枠から再びプロットを始めます。スイープチャート
このモードはスコープチャートに似ていますが、プロットが右枠に到達したらプロットは削除されません。その代わり、垂直線が左側から右側に動いてその線に沿って古いデータを新しいデータで更新されます。
保存時間設定
時間アイコンをクリック、下図の保存時間設定画面が出ます
| Item | Comment |
|---|---|
| 保存時間 | 1回保存データの長さ、単位:秒 |
| 保存間隔 | 複数回数保存時の待ち時間、単位:秒 |
| 保存回数 | 保存回数設定、単位::回 保存回数設定値0時、保存回数が制限しない、データ収集停止まで指定間隔で保存する。 保存回数設定値1時、保存間隔設定値無効にする。 保存回数設定値1以外時、保存データ形式はIMDしかない |
「OK」ボタンをクリック後、時間指定保存機能が有効にする
基本画面
基本画面は下図の通りです。
各エリアの説明
- Y軸、電圧値表示。No.6エリアで「X1」倍率の場合、1DIVの表示値は1Vです。
- X軸、時間値表示。No.7エリアで0.5s/divの場合、1DIVの表示値は0.5秒です。
- 波形表示のプログレスバー。移動して波形位置を再指定できます。
- 波形表示エリア。ファイルモードの場合、マウスを押しながら左右に移動可能です。
- 波形の基準点位置です。マウスを押しながら上下に移動可能です。
- 波形表示制御エリア。詳しくは下記で説明します。
- X軸の表示時間設定、単位:秒/div。
- 制御エリアの設定をリセットします。
波形表示制御エリア
各CH制御パラメータの説明
- チャンネル波形の表示色を設定します。
- 表示チャンネル番号を選択します。
- 指定データのMarkBit表示。[無]の場合はMarkBitを表示しません。
- 波形表示の有無を設定します。
- Y軸表示の拡大倍率を設定します。
- Y軸表示のオフセット設定、単位:V。
- データ処理関数を選択します。現在のCHの生データを関数処理してから表示します。[無]の場合は生データで表示し、関数処理を行いません。
ポップアップメニュー
基本画面でマウスを右クリックすると、ポップアップメニューが表示されます。
ポップアップメニューの説明
名前を付けて保存...
現在の生データを再保存、CH、保存形式など再編集可。詳しく[《名前を付けて保存設定画面》](#5.15 名前を付けて保存設定画面)にご参考くださいファイルを追加
現在のファイルをベースにして、新しいファイルを追加します。詳しくはファイル追加操作例をご参照ください。カーソル機能
詳しくは[カーソル機能]のページをご参照ください。ファイル情報
開かれたファイルの情報を表示します。チャンネル名と単位は再編集可能ですが、他のパラメータは編集不可です。
下図参考:
ファイル追加操作例
目的:ファイルのマージ(結合)。2つのIMDファイルを1つのIMDファイルにマージします。
例えば、ファイルAは2チャンネル、ファイルBは3チャンネルの場合、マージしたファイルCは5チャンネルになります。
- ファイルAを開きます。
- マウスを右クリックし、[ファイルから追加]を選択します。
- 追加ファイルダイアログでファイルBを選択します。
- 波形表示画面に5チャンネルの波形が表示されます。
- マウスを右クリックし、「名前を付けて保存...」をクリックすると、「名前を付けて保存」画面が表示されます。
- 「名前を付けて保存」画面で全てのCHを選択し、OKボタンをクリックします。
- ファイル名Cを入力して保存ボタンをクリックすると、5チャンネルのファイルCが保存されます。
FFT画面
操作方法:Homeアイコンを左クリックして、FFT画面に入ります
1. 波形サムネイルおよびスクロールバー
2. サムネイル選択範囲の拡大表示
3. 1回FFT演算後波形表示
4. 共通設定
FFT演算チャンネル選択。チャンネル変更後、1と2の表示波形も変わります。
5. 元波形表示チャート設定
| Item | Comment |
|---|---|
| 波形色 | 拡大波形の色設定 |
| Y軸最大値 | 拡大波形Y軸の最大値設定;単位:V |
| Y軸最小値 | 拡大波形Y軸の最小値設定;単位:V |
6. FFTチャート表示設定
| Item | Comment |
|---|---|
| 波形色 | ③チャート、FFT波形の色設定 |
| 表示方式 | 3種類の方式が設定可能です 電圧値表示:FFTチャートのY軸を電圧値で表示、単位:V dB値表示:FFTチャートのY軸をdB値で表示、単位:dB 物理値表示:FFTチャートのY軸を物理値で表示、単位:不定 |
| X軸対数 | 選択時:③チャート、FFT波形のX軸を対数間隔方式で表示 未選択時:③チャート、FFT波形のX軸を線形方式で表示(等間隔) |
| Y軸対数 | 選択時:③チャート、FFT波形のY軸を対数間隔方式で表示 未選択時:③チャート、FFT波形のY軸を線形方式で表示(等間隔) |
| X軸最小値 | ③チャート中、FFT波形X軸の最小値;単位:Hz。 |
| X軸最大値 | ③チャート中、FFT波形X軸の最大値;単位:Hz。 |
| Y軸最小値 | ③チャート中、FFT波形Y軸の最小値;単位:表示方式をご参照ください。 |
| Y軸最大値 | ③チャート中、FFT波形Y軸の最大値;単位:表示方式をご参照ください。 |
| 波形図 | FFT波形の表示モード。詳細はFFT波形表示方式をご参照ください。 |
7. FFT演算パラメータ設定
| Item | Comment |
|---|---|
| FFT点数 | 変更後、②の元波形表示画面も変わります。設定可能値:64、128、256、512、1024、2048、4096、8192 |
| FFT窓関数 | スペクトル漏れを低減するため、異なる切り出し関数で信号を切り出します。切り出し関数を窓関数(Window Function)と呼びます。設定値:無、hamming、hanning、サイン関数、三角関数 |
| 帰頻モード | 詳細はFFT帰頻モードをご参照ください |
8. ファイル形式
ファイル形式の設定内容は、元波形ファイルを読込んだ場合のみ有効です。リアルタイム収集時は無効です。
| Item | Comment |
|---|---|
| オーバーラップ率(%) | FFT演算データの間隔。設定範囲:0~99、単位:% 例:FFT演算点数1024、50%オーバーラップ率の場合、 第1回FFT演算データ:0~1024 第2回FFT演算データ:512~1536 第N回FFT演算データ:512*(N-1)~512*(N-1)+1024 |
| 「開始」ボタン | 連続FFT演算して表示します 「開始」ボタンをクリックすると演算開始、「開始」ボタンは「一時停止」と表示され、同時に「停止」ボタンが有効になります。 「一時停止」ボタンをクリックすると演算が一時停止します。 「停止」ボタンをクリックすると演算が停止します。 |
| 「停止」ボタン | 「停止」ボタンをクリックすると演算が停止します。 |
| 「演算」ボタン | 1回のみ演算するボタンです。操作方法: FFT演算パラメータ、FFT演算点数、FFT窓関数などを設定します FFT演算位置を指定します。マウスで元波形拡大枠内を移動し、演算する波形範囲を選択します。 「演算」ボタンをクリックすると、指定範囲のデータをFFT演算して表示します。 |
| 「保存」ボタン | 「保存」ボタンをクリックすると、FFT波形データをCSVファイルに保存します。保存時に「ヘッダー定義内容を保存しますか?」というメッセージが表示されます。 「Yes」の場合:FFT演算パラメータとデータを一緒に保存します。 「No」の場合:FFT演算データのみ保存します。 |
FFT演算データ
ファイルモード
生データをファイルから読み込み、FFTを演算します。リアルタイムモード
生データをデバイスから読み込み、FFTを演算します。リアルタイムモード操作方法
- デバイス型番を選択
- 計測開始をクリック
デジタル画面
操作方法:Homeボタンを連続クリックすると、デジタル画面に切り替わります。
リアルタイム収集中に、各チャンネルのデータをリアルタイム表示できます。
① パラメータ設定
| Item | Comment |
|---|---|
| 表示CH | 表示チャンネル数の設定、設定範囲:4~16 設定変更後、図中の②と③の表示列も変わります。 |
| 表示値モード | ②エリアの表示内容も連動して変わります。電圧値と物理値に対応。 |
| 表示間隔 | 表示データの更新間隔。 |
| 演算モード | 指定間隔内の収集データの演算方式。 |
| 最小値 | 最小値で表示します。 |
| 最大値 | 最大値で表示します。 |
| 平均値 | 平均値で表示します。 |
| 先頭 | 間隔内の最初のデータで表示します。 |
| 中間 | 間隔内の中間のデータで表示します。 |
| 最後 | 間隔内の最後のデータで表示します。 |
| 小数桁 | デジタル表示時の小数点以下桁数 |
② デジタル出力
| Item | Comment |
|---|---|
| 1行目 | 表示チャンネル設定 |
| 2行目~10行目 | 各チャンネルデータ表示履歴; 1データ更新時、9行目のデータが10行目に移動、8行目のデータが9行目に移動、...、2行目のデータが3行目に移動し、2行目のデータが常に最新データとなります。 |
③ データ変化チャート
リアルタイム収集中、0Vを中心に上下変動し、0V以上は赤色バー、0V以下は緑色バーで表示します。
操作手順
- 収集カードの種類を選択
- 表示パラメータを設定
- 「収集開始」ボタンをクリック、収集開始と同時にデータをリアルタイム表示します。
名前を付けて保存設定画面
基本画面モードで、マウス右クリックで「名前を付けて保存...」メニュー項目を選択すると、名前を付けて保存操作画面が表示されます。
① 保存チャンネル選択
ユーザーは追加ボタン(> または >>)で保存チャンネルを追加でき、削除ボタン(< または <<)で追加済みのチャンネルを削除できます。
② データ範囲設定
保存データ長を設定します。
| Item | Comment |
|---|---|
| 開始時刻 | 保存開始時刻、編集可、単位:秒。Enterキーで設定更新 |
| 終了時刻 | 保存終了位置、編集可、単位:秒。Enterキーで設定更新 |
| 開始位置 | 保存開始位置、編集可、単位:点数。Enterキーで設定更新 |
| 終了位置 | 保存終了位置、編集可、単位:点数。Enterキーで設定更新 |
| 元データ長 | 編集不可、元ファイルのデータ長、単位:秒 |
| 元データ個数 | 編集不可、元ファイルのデータ点数 |
| 新ファイル時間 | 編集不可、新ファイルのデータ長、単位:秒 |
| 新ファイルデータ個数 | 編集不可、新ファイルのデータ点数 |
| サンプリング周波数 | 編集不可、表示のみ、単位:Hz |
③ データ変換パラメータ設定
変換方式:データ変換方式、以下の2種類があります
- 増幅/減幅
データ大小変換、変換値 = 元の値 × 係数 - FIRフィルタ
FIR(Finite Impulse Response)フィルタ:有限長単位インパルス応答フィルタ、非再帰型フィルタとも呼ばれます。デジタル信号処理システムにおける最も基本的な要素であり、任意の振幅周波数特性を保証しながら厳密な線形位相特性を持ちます。また、単位サンプル応答が有限長であるため、安定したシステムです。FIRフィルタは通信、画像処理、パターン認識などの分野で広く応用されています。
フィルタ畳み込み方程式は以下の通りです:
- 増幅/減幅
係数
変換方式が「増幅/減幅」の場合に有効です。FIR変換方式
変換方式が「FIRフィルタ」の場合に有効です。- ローパスフィルタ
ローパスフィルタは、直流からあるカットオフ周波数(fCUTOFF)までの信号を通過させます。汎用フィルタの2次伝達関数のハイパス係数とバンドパス係数をゼロにすると、2次ローパスフィルタの伝達式が得られます。 - ハイパスフィルタ
ハイパスフィルタは、ある周波数以上の信号成分を通過させ、その周波数以下の信号成分を大幅に抑制するフィルタです。その特性は時間領域と周波数領域でそれぞれインパルス応答と周波数応答によって記述されます。 - バンドパスフィルタ
バンドパスフィルタは、特定の周波数範囲内の周波数成分を通過させ、他の範囲の周波数成分を極めて低いレベルに減衰させるフィルタです。アナログバンドパスフィルタの例として、抵抗-インダクタ-コンデンサ回路(RLC回路)があります。これらのフィルタは、ローパスフィルタとハイパスフィルタを組み合わせて生成することもできます。 - バンドストップフィルタ
バンドストップフィルタ(bandstop filters、略称BSF)は、ほとんどの周波数成分を通過させますが、特定範囲の周波数成分を極めて低いレベルに減衰させるフィルタです。ノッチフィルタ(notch filter)は特殊なバンドストップフィルタで、阻止帯域が非常に狭く、高いQ値(Q Factor)を持ちます。
- ローパスフィルタ
FIR窓関数
窓関数法は、理想的な低周波特性を持つ無限長デジタルフィルタの単位インパルス応答を有限区間で近似することにより、フィルタの単位インパルス応答を決定する方法です。設計したローパスフィルタに適切な可変変換を施すことで、ローパス、ハイパス、バンドパス、バンドストップフィルタを容易に設計できます。None
実際は矩形窓関数で、関数式は以下の通りです:Tapered
Tukey窓、関数式は以下の通りです:
Triangular
三角窓、Bartlett窓とも呼ばれます。関数は以下の通りです:
- Hanning
ハニング窓、レイズドコサイン窓とも呼ばれます。関数は以下の通りです:
- Hamming
ハミング窓、改良型レイズドコサイン窓です。関数は以下の通りです:
- Blackman
ブラックマン窓、2次レイズドコサイン窓とも呼ばれます。関数は以下の通りです:
- Kaiser
カイザー窓、関数式は以下の通りです:
解析回数
入力信号と出力信号の関係を定義する差分方程式は以下の通りです:
周波数下限
ローパス制限周波数設定、単位:Hz周波数上限
ハイパス制限周波数設定、単位:Hz
パラメータ設定完了後、OKボタンをクリックすると、名前を付けて保存ファイルダイアログが表示されます。この画面で、ユーザーは保存ファイル形式(IMD、CSV、WAVなど)およびファイル名を変更できます。その後、保存ボタンをクリックすると新しいファイルが保存されます。
トリガ機能
Daq3のトリガ種類は2種類あります:ソフトウェアトリガとハードウェアトリガ。
ハードウェアトリガは収集カードのパラメータ設定により実現します。収集カードによって設定方法が若干異なります。詳細は収集カードのハードウェア仕様をご参照ください。
トリガパラメータ設定は収集カード入力のDLLファイルに対応しています。以下、EC-2310 ADCを例に説明します。
トリガ設定画面説明
トリガパラメータ設定は各収集カードのパラメータ設定画面内にあります。収集カードによって設定パラメータが若干異なります。
下図はEC-2310 ADCの設定画面例で説明します。
トリガ種類
トリガ監視種類の設定、3種類あります- 無:トリガなし。
- ソフトウェア:ソフトウェアトリガモード有効。詳細は下記のソフトウェアトリガモードをご参照ください。
- ハードウェア:ハードウェアトリガモード有効。詳細は下記のハードウェアトリガモードをご参照ください。
ソフトウェアトリガ種類
「トリガ種類」でソフトウェアを選択時に有効です。
3つのソフトウェアトリガ種類があります。詳細は[《ソフトウェアトリガ》](#6.2 ソフトウェアトリガ)をご参照ください。- 指定チャンネルデータの立上りまたは立下りトリガ
- 指定チャンネル指定データビットの立上りまたは立下りトリガ
- 指定チャンネルの波形周波数の立上りまたは立下りトリガ
ハードウェア種類
「トリガ種類」でハードウェアを選択時に有効です。
3つのハードウェアトリガ種類があります。詳細は[《ハードウェアトリガ》](#6.3 ハードウェアトリガ)をご参照ください。外部スタートトリガ、外部スタート入力信号の立上りまたは立下り時にトリガ発生
レベルトリガ、指定チャンネルデータの立上りまたは立下りトリガ
レベルトリガ、指定チャンネルデータの上限または下限トリガ
チャンネル
トリガデータのチャンネル指定、単位:チャンネル番号
- トリガ電圧値
トリガ電圧値設定、単位:V
- bit
指定チャンネル指定データビット設定、単位:データのビット番号
- 周波数
トリガ監視の周波数、単位:Hz
- ロースライス
波形識別のロースライス設定、単位:V
- ハイスライス
波形識別のハイスライス設定、単位:V
トリガ前データ
トリガ発生前に保存するデータ長、単位:秒
収集開始後からトリガ発生前までのデータがこの設定値より大きい場合、保存データ長はこの設定値になります。逆の場合は、収集開始後からトリガ発生前までの全データを保存します。トリガ後データ
トリガ発生後に保存するデータ長、単位:秒
総保存時間 = トリガ前データ数 + トリガ後データ数
- トリガ回数
トリガ回数の上限。0に設定した場合、トリガ回数は無制限です。
ソフトウェアトリガ
ソフトウェアトリガは、ADCから取得したデータを監視し、トリガ条件を満たした後、表示とデータ保存を開始します。
ソフトウェアトリガには以下の3種類があります。
電圧値トリガ条件
Item 立上りトリガ 立下りトリガ 監視データ 指定CH 指定CH トリガ閾値 電圧値 電圧値 トリガタイミング >= ハイスライス <= ロースライス トリガ前のデータ 有 有 トリガ後の処理 データ保存、表示など データ保存、表示など ビットトリガ条件
Item 立上りトリガ 立下りトリガ 監視データ 指定CH 指定CH トリガ閾値 指定bit 指定bit トリガタイミング 指定bit値 > 0 指定bit値 < 1 トリガ前のデータ 有 有 トリガ後の処理 データ保存、表示など データ保存、表示など 周波数トリガ条件
Item 立上りトリガ 立下りトリガ 監視データ 指定CH 指定CH トリガ閾値 周波数(Hz) 周波数(Hz) トリガタイミング >= トリガ周波数 <= トリガ周波数 トリガ前のデータ 有 有 トリガ後の処理 データ保存、表示など データ保存、表示など
ハードウェアトリガ
ハードウェアトリガは、ADCパラメータを設定した後、ADC自身が監視を行い、トリガ条件を満たした時に上位機にデータを送信します。
EC-2310 ADCの場合、以下の3種類が設定可能です。
外部スタート
この機能はADCにExternal Startピンが必要で、トリガ信号をこのピンに接続する必要があります。具体的なトリガ条件は以下の通りです:Item 立上りトリガ 立下りトリガ 監視データ 指定CH 指定CH トリガ閾値 電圧値 電圧値 トリガタイミング > トリガ閾値 < トリガ閾値 トリガ前のデータ 有(他の収集カードでは無い場合もあります) 有(他の収集カードでは無い場合もあります) トリガ後の処理 データ転送 データ転送 指定チャンネル立上りまたは立下りトリガ
この機能はトリガ信号を対象チャンネルのピンに接続する必要があります。具体的なトリガ条件は以下の通りです:Item 立上りトリガ 立下りトリガ 監視データ 指定CH 指定CH トリガ閾値 電圧値 電圧値 トリガタイミング > トリガ閾値(その前は < トリガ閾値であること) < トリガ閾値(その前は > トリガ閾値であること) トリガ前のデータ 有(他の収集カードでは無い場合もあります) 有(他の収集カードでは無い場合もあります) トリガ後の処理 データ転送 データ転送 指定チャンネル上限または下限トリガ
この機能はトリガ信号を対象チャンネルのピンに接続する必要があります。具体的なトリガ条件は以下の通りです:Item 上限トリガ 下限トリガ 監視データ 指定CH 指定CH トリガ閾値 電圧値 電圧値 トリガタイミング トリガ閾値以上 トリガ閾値以下 トリガ前のデータ 有 有 トリガ後の処理 データ転送 データ転送
生データ保存
ここでは主にリアルタイム収集時にファイルへ保存する方法を紹介します。
3つの方法があります。
通常保存モード
保存開始
計測開始 + 収集開始
上記2つのボタンが同時に有効になった時、データの保存を開始します。
ボタンをクリックする順番は関係ありません。保存終了
計測停止 / 収集停止保存ファイル名
保存停止後、保存ファイル名のダイアログボックスが表示されます。ユーザーは任意のデータファイル名に変更できます。
指定時間保存
保存開始
計測開始 + 収集開始 + 時間指定
上記3つのボタンが同時に有効になった時、データの保存を開始します。
ボタン操作の順番には、以下の3つのモードがあります。
① 時間指定ON > 収集ON > 計測開始
② 時間指定ON > 計測開始 > 収集ON
③ 収集ON > 時間指定ON > 計測開始保存終了
指定時間に達すると、自動的に停止します。保存ファイル名
指定時間設定画面の保存回数によって異なります。
保存回数が1の場合、保存終了後にファイル書き込みダイアログボックスが表示され、ユーザーは任意のデータファイル名に変更できます。
保存回数が1より大きい場合、保存位置:環境設定画面で設定できます。デフォルトは[Daq3\Raw]フォルダーです。
ファイル名のフォーマットは以下の通りです:Times_NNNN_yyyymmdd_hhnnss.imd注意保存回数が1より大きい場合、保存ファイル形式はIMD形式に固定されます。
トリガ保存
計測中にトリガ条件が設定されている場合、トリガ条件を満たすと、データが自動的にファイルに保存されます。
トリガ条件の設定は各入力デバイスのパラメータ設定画面で行います。以下はEC-2310を例にした説明です。
上図画面のトリガ条件設定は以下の通りです:
| Item | Condition |
|---|---|
| トリガ監視モード | ソフトウェアトリガ |
| トリガ発生条件 | チャンネル1の電圧値が1Vより大きい時 |
| 保存時間 | 3.5秒 (トリガ前のデータ数 + トリガ後のデータ数) |
| トリガ発生回数 | 無制限(0は無制限、5に設定した場合は5回のトリガ後に自動停止) |
保存開始
Step1:トリガ条件を設定します。
Step2:計測開始 + 収集開始をクリックします(2つのボタンが同時に有効になった時、データの監視を開始します。ボタンをクリックする順番は関係ありません)。保存終了
トリガ回数に達すると自動的に停止します。保存ファイル名
保存位置は環境設定画面で設定できます。デフォルトは[Daq3\Raw]フォルダーです。
ファイル名のフォーマットは以下の通りです:
yyyymmdd_hhnnss.imd注意保存ファイル形式はIMD形式に固定されます。
カーソル定位機能
カーソル定位機能は主に生データの分析に使用され、同時に最大4本のカーソル線を操作できます。
開くと閉じる
開く
Daq3でデータファイルを読み込んだ後、基本波形表示画面でマウスを右クリックしてメニューを表示し、[カーソル定位]を選択すると、カーソル定位ダイアログボックスが表示されます(下図参照)。
閉じる
カーソル定位画面の右上にあるボタンをクリックすると、カーソル定位画面が閉じます。 
カーソル基本機能
下図はカーソルの基本操作画面です。
| No. | Comment |
|---|---|
| ① | カーソル線の拡張機能ボタン、詳細は下記をご参照ください。 |
| ② | チャンネルの設定、カーソル表示データのチャンネル番号。 |
| ③ | X軸表示値設定 点数:⑩の表示値はポイントで表示、単位:点。 時間:⑩の表示値は時間で表示、単位:m秒。 |
| ④ | Y軸表示値設定 電圧値:⑪の表示値は電圧値で表示、単位:V。 物理値:⑪の表示値は物理値で表示、単位:各チャンネル仕様による。 |
| ⑤ | 4本のカーソル線の色設定。 |
| ⑥ | 最小値ボタン、このボタンをクリックすると、No.1カーソル線が最小値の位置に移動します。 |
| ⑦ | 最大値ボタン、このボタンをクリックすると、No.2カーソル線が最大値の位置に移動します。 |
| ⑧ | No.3カーソル線の表示有無。 |
| ⑨ | No.4カーソル線の表示有無。 |
| ⑩ | 4本のカーソル線の位置の表示場所(点数/時間)。 |
| ⑪ | 4本のカーソル線の数値の表示場所(電圧値/物理値)。 |
カーソル定位拡張機能
カーソル基本画面の左上にある[下向き]ボタンをクリックすると、拡張画面が表示されます。
| No. | Comment |
|---|---|
| ⑫ | 関数番号、最大50個設定可能。 |
| ⑬ | 関数名、関数番号のコメント、ユーザーが任意の文字列を入力。 |
| ⑭ | 演算関数の数式、ここで編集可能。詳細は《カーソル演算公式》をご参照ください。 |
| ⑮ | 演算データ表示エリア、演算結果がここに表示されます。 |
| ⑯ | 保存ボタン、現在設定されている数式を保存します。 |
| ⑰ | 演算ボタン、現在設定されている数式で演算を実行します。 |
| ⑱ | カーソル線の種類をここで選択可能。 |
| ⑲ | カーソルの開始・終了位置をここで設定可能、単位:%。 |
カーソル演算公式
公式用キーワード(特別変数)は以下の8つがあります
- X1、X2、X3、X4
X軸の時間/点数(③の設定によって決定) - Y1、Y2、Y3、Y4
Y軸の電圧値/物理値(④の設定によって決定)、このキーワードはあまり使用されません
関数モード
| Function | Comment |
|---|---|
| +、-、×、/、() | 一般的な数式作成時に使用(加、減、乗、除、括弧)。 例1:X2-X1はカーソル線2の点数(または時間) - カーソル線1の点数(または時間)を示します。 例2:Y3-Y2はカーソル線3の電圧値(または物理値) - カーソル線2の電圧値(または物理値)を示します。 |
| Count | 指定したカーソル線範囲内のパルス数を演算します。 公式:Count(X1、X2、slice) / count(x1、x2、loslice、hislice) ※Slice、loslice、hisliceはパルス認識用のスライスレベルを示します。一般的に電圧値を使用します。 |
| Min | 指定したカーソル線範囲内の最小値を演算します。 公式:Min(X1、X2) |
| Ave | 指定したカーソル線範囲内の平均値を演算します。 公式:Ave(X1、X2) |
| Max | 指定したカーソル線範囲内の最大値を演算します。 公式:Max(X1、X2) |
| Sum | 指定したカーソル線範囲内のすべてのデータを累積します。 公式:Sum(X1、X2) |
| Dev | 指定したカーソル線範囲内の偏差(最大値 - 最小値)を演算します。 公式:Dev(X1、X2) |
| StDev | 指定したカーソル線範囲内の標準偏差を演算します。 公式:stdev(X1、X2) |
| PosMin | 指定したカーソル線範囲内の最小値の位置を演算します。 公式:posmin(X1、X2) |
| PosMax | 指定したカーソル線範囲内の最大値の位置を演算します。 公式:posmax(X1、X2) |
| PosLo | 指定したカーソル線範囲内で、設定値を下回る最初の位置を演算します。 公式:poslo(X1、X2、value) |
| PosHi | 指定したカーソル線範囲内で、設定値を上回る最初の位置を演算します。 公式:posHi(X1、X2、value) |
Q&A
Daq3での収集後にデータを保存できない
Windows 7以上のオペレーティングシステムでは、一部のフォルダー(例:「C:」、「C:\Program files」など)への書き込みが制限されています。制限のないフォルダー(例:[C:\ELMEC\RawData])を選択して保存してください。Daq3の操作中に原因不明のエラーが発生する
[daq3.exe]ファイルを右クリックし、「管理者として実行」を選択してください。高速データ収集カードを使用し、低速サンプリング周波数で収集する場合、波形更新に遅延が発生する
一部のADC(特に高速ADC)はキャッシュが比較的大きく、キャッシュが満杯になってからPCへデータを送信するためです。その結果、PCへの送信間隔が長くなり、更新に遅延が生じます。
例:ADCのキャッシュが1MBの場合、1CH、1KHzで収集すると、波形の更新は10秒に1回しか行われません。ログファイル名は何ですか?どこに保存されますか?
ログファイル名:log.txt、保存位置:Daq3\Bin(32bit)またはDaq3\Bin64(64bit)